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Licence Agreement

If the purchaser does not agree with the terms of this agreement then the 
full product should be returned for a refund of the purchase price.  Use 
of the software and associated documentation implies acceptance of this 
agreement.

CaRob Computing grants the purchaser the right to use one or more 
copies of this software within one campus of your organisation or school

You may make copies of the written materials accompanying the 
software.

The purchaser may not rent or lease or lend the software.  The purchaser 
may not reverse engineer, decompile, or disassemble the software.

In no event shall CaRob Computing be liable for any damages, including 
loss of data, or any other special, incidental, consequential, or indirect 
damages arising out of the use of , attempted use of, or inability to use 
this software or accompanying documentation, however caused and 
on any theory of liability.   Under no circumstances shall the liability of 
CaRob Computing exceed the actual amount paid to and received by 
CaRob Computing in connection with the particular copy of NetBookIt

© CaRob Computing 2010

CaRob Computing 
	 153 Must St
	 PORTLAND VIC 3305
	 Ph:	 (03)  55232120
	 Fax:	 (03)  5523 5144

	      email: 	 carobcomputing@hotkey.net.au
   	      web:	 	 www.carobcom.com
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Any software inevitably evolves and this documentation may not always 
represent all the features available, or the screen shots may look 
different to actual.

You may check www.carobcom.com for a .pdf version of this document 
that should be current.
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Network administrators 

Please read this chapter fully before you start to configure NetBookIt on 
your network.

NetBookIt and BookIt 

BookIt is a booking information system comprising a set of Windows 
programs operating on a set of data.  The system functions over a local 
area network.

NetBookIt is a browser based booking module that operates on the same 
data as BookIt for making bookings.  Setup and configuration are done 
with BookIt.  

Advantages of NetBookIt over BookIt for bookings

Users are not limited to Windows workstations.  Any browser on any •	
platform will work.

You have the potential to be able to make bookings from outside your •	
LAN via the internet.

Users do not require access to the BookIt data folder, so data is •	
protected.

Data is modified by the NetBookIt Server on the server, not via a •	
network transaction. Network transactions carry a small but real risk 
that they may not fully complete a disk write due to communications 
disruption.

Performance is better because data files don't travel to the client.•	
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Setting up NetBookIt

NetBookIt has two executable files:

NetBookIt3.exe

NetBookIt3.exe is designed to be installed as a Windows service.  
Don't run it independently, except for testing.

NetBookItMgr.exe installs and starts NetBookIt3 as a Windows service.  
It allows you to set or change the Port that NetBookIt3 listens on.
It uninstalls NetBookIt3 as a service.

These programs are installed in the BookIt3 folder by the BookIt3 install.  
There is no separate NetBookIt installation (as in previous version).

Recommended configuration of BookIt and NetBookIt

Keep all program files and data in the BookIt3 folder.

Run NetBookIt from this folder
Perform administration with BookIt.exe in this folder
Do not provide general staff access to this folder.  They will use 
NetBookIt for their bookings, not BookIt or BI.

The BookIt administrator(s) needs 
Full Control of all files in this folder and subfolders  •	
A shortcut to BookIt.exe•	

Alternative Configuration 1

Same as recommended configuration (above), but provide access for 
general staff to BI.exe or BookIt.exe for bookings. There is no good 
reason for this configuration except possible historical practice within 
your organisation.  If you are new to BookIt, this is not recommended.

Downsides

Data integrity issues may arise more often•	
Staff require Modify rights of all data files•	
General staff shortcuts to BI.exe must be set up.•	

See Redirect bookings to NetBookIt, page 9.  It avoids these issues.

	 ... continued next page
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Alternative Configuration 2 

Use this method if you have previously run NetBookIt and BookIt from 
separate folders.

Have BookIt3 as your main working folder, running NetBookIt.  This •	
folder would be named NetBookIt historically.
Copy the above folder, but name it BookIt,  perhaps on another •	
server.  
Set Staff desktop shortcuts to BookIt or BI in the BookIt folder•	
Redirect BookIt to find its data in the NetBookIt folder•	

Redirecting BookIt

Run BookIt.exe in the BookIt folder

Go to Setup > Set Location of BookIt (& NetBookIt) data

As shown in the window below, Activate the Path and set the 
UNC path to the NetBookIt folder.

When BookIt is started or restarted, it will expect its data to be in this 
location.
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Redirect bookings to NetBookIt

You may force users to make bookings through NetBookIt even if they 
have opened BookIt.exe.  There is a new feature in BookIt3 that redirects 
the booking function to NetBookIt.

Go to Setup > Operational Settings

Enter the NetBookIt URL and Tick the Disallow button as shown here.

Then test the link using the button.

Now, in BookIt when staff try to make a booking they receive this 
message...

The hyperlink calls up NetBookIt in their browser.

If someone is logged into BookIt as Admin, they do not get this: they get 
the usual windows booking window.
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Configuring NetBookIt

Run NetBookItMgr.exe (the 
BookIt Admin password will be 
required)

NetBookIt's main window 

Setting the Port

Click Change Port

If Port 1088 is used by another 
service then it won't work for 
NetBookIt.  

To see ports currently being used, copy
   	 netstat -an |find /i "listening" 
from the text box in the above window and paste it at the command 
prompt as shown below.

The second 
column of the 
listing shows 
the ports (after 
the colon) being 
used.  

If Port 1088 is 
used, choose 
another e.g. 1090

If you change the port,  restart NetBookIt.

The Port number is saved in a configuration file Settings.ini which may 
be edited in Notepad if necessary.

When NetBookIt3.exe starts, it reads this port number from the .ini 
file.  After that, changing the port won't affect NetBookIt3 unless you 
Restart the service.
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Testing NetBookIt

To test NetBookIt, run the executable NetBookIt3.exe 

In Windows 7, the firewall prompts with a warning 
on the first running and you have to allow access. 

You may receive the same type of message and 
need to update your firewall exceptions

Server 2008 firewall does not give a message. 
Add a port exception to the firewall. 
(Accessed from Administration Tools > Windows 
Firewall with Advanced Security)
Set a new inbound and outbound rule for the 
program - select Netbookit service (Netbookit3.
exe) from the Bookit folder.

Once NetBookIt3 is running, check if a browser can find 
it.

From another computer, open a browser and enter the server's IP 
address and port e.g. 10.74.21.11:1088 or http://servername:1088

If the browser is on the same computer as NetBookIt! use 127.0.0.1:1088 
or http://localhost:1088/

If it fails, and you know that the port is not being used by another 
application, check the proxy exceptions (next page).

When you know it is working, close NetBookIt3 and install it as a service 
(Page13)
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Proxy Exceptions

If you run a proxy server, then client browsers will need to have an 
exception added for the NetBookIt server, if one does not already exist.  
You may do this with a group policy or by editing individual machines.  
Editing the exceptions is shown below for IE.

For Internet Explorer, go to Tools > Internet Options 
> Connections Tab (left)

Then LAN Settings (below)

Then the Advanced button...

Enter the IP address of the NetBookIt server 
here.
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Installing NetBookIt3 as a service

Run NetBookItMgr.exe

On later Windows (e.g. Windows7) you need to Run as Administrator or it 
won't be able to install a service.

Click Windows Service Manager and keep it open.

Windows Service Manager (Win 7)

Click Install and Start As Service on the NetBookItMgr window
The expected behaviour is a slight pause, and the NetBookItMgr window 
closes.  This indicates that the service has installed.

On the Windows Service Manager, go to Action menu > Refresh
You should see "NetBookIt3" as a service.  If you see "NetBookIt" it is the 
BookIt2 version.

NetBookIt 3 functioning as a service
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Disable the Window

In the Service manager, go to the Log On tab in NetBookIt3 
Properties.

Uncheck 'Allow Service to Interact with Desktop'  and OK it.

Changing the NetBookIt3 Port

You do not have to remove NetBookIt3 as a service to change the port. 
Just Restart it using the Windows Service Manager.

Removing the NetBookIt3 Service

This is a 3 step process.

1. Run NetBookItMgr.exe
2. Run Windows Service Manager

Use the Right-click menu to Stop the Service

Keep the Service Manager open

3. Return to the NetBookItMgr and close the window.

Go to the Service Manager, Action Menu > Refresh, and NetBookIt3 
should be no longer in the list.
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Registration

NetBookIt requires a registration code for continued operation.  Without 
the code it will function for 45 days from when the registration file is 
created.

The Registration file is named iClient3.tps and contains your organisation 
name and registration code.

Make sure you have a copy of iClient3.tps and client3.tps in a safe but 
convenient location.  Otherwise if the file is lost or over-written you would 
have to contact CaRob Computing.

Until fully registered, a message shows the time remaining.

CaRob Computing sends the code via fax or email when payment is 
received.

Enter the code from the File Menu in BookIt.

Enter the code and 
press <TAB> for 
verification.

After NetBookItMgr is restarted, the message will change.
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Configuring user access to NetBookIt

All configuration (apart from the port number) must be performed through 
BookIt.exe.

Password Options

Go to BookIt Setup menu > Set NetBookIt Password

You may set:

	• No password
	• A general password for all users
	• A unique password for each user

Use No Password if BookIt is accessed via a secure portal.  

Use a password if NetBookIt is potentially accessible by non-authorised 
users. 

If you choose staff specific passwords it is best to import them from text 
file if you have more than a handful to set.  See the BookIt User Guide 
and Input/Output  menu  >  Import/Export  > Import User names.  

You may set or edit the passwords yourself by clicking Set Staff 
Passwords.  
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Clicking the Set Staff Passwords button brings up the following table:

Double click any password to 
change it.

Arrow keys move up or down, 
retaining the edit function.

<ENTER> will accept.  <ESC> 
will cancel the edit.

Passwords may be printed in a form convenient for handing to staff.
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Section 2	

NetBookIt User Guide
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Getting on to NetBookIt

NetBookIt3 provides browser based bookings on BookIt.
It offers all of the booking features of BookIt3, including:

Email notification of bookings•	
Access to password protected resources •	
Recurrent bookings•	
Linked resources •	
Booking multiple sessions in one day •	
Booking the entire category•	
Prohibit making bookings too far ahead of time•	
Viewing the changes log •	

You are not limited to Windows machines, but can use Mac or any web 
device.

The NetBookIt administrator will have set up a web address or a link for 
you to access NetBookIt.

A password may or may not be required, as determined by your local 
NetBookIt administrator.  If required, it may be a general password for all 
users, or a user specific one.

If no password is required, the first window appears.

(Screen shots may look different as we update NetBookIt but the logic 
will be the same)
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Making or viewing a booking

Select the category of item for which a booking is to be made or viewed. 
(Use the drop list)

Category Button

You choose a date and see the 
day's bookings for all items in 
that category.

Item Button

You choose an item and a date 
and see bookings for the week.

Click the Category button to select a date.   
Today's date shows in red.

Prev and Next move through the months.

Click on a date to bring up the Daily View (overleaf).
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The daily view shows all items in one category.  If there are more than 
four items in the category, scroll buttons will display.

Prev Day and Next Day scroll through dates.

If bookings have an update button they are usually bookable.  
An exception is if a booking has been tagged Read-Only by the 
administrator.  You are allowed to call up the booking, but would not be 
able to change it.

If cells have no update button, they are not bookable. This may because 
they are permanently timetabled, on weekends, or are too far ahead.

See page 24 for the update form.

Colour codes on the booking grid

The colour codes on the cells are the same as used in BookIt

Blue			   Available for booking
Bright Yellow		  A current booking
Pale Yellow		  A booking that has been changed
Mauve 			   A permanent or timetabled booking 
Green			   A timetabled booking that the occupant may 	
				   relinquish if consulted, ie. negotiable.
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The Item Button on the main window

If you select Item rather than Category, you are required to select a 
specific resource followed by  a date.

In this example, a computer room is being selected.

Click on a specific date to bring up the Weekly View for that item.

Weekly View

You may scroll through the weeks on this resource.  
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The update form

The booking form can have many options depending upon how that 
category of resource has been configured by your BookIt Administrator.

This is the simplest of all:  the 
User name only.

All bookings must have a user 
name.

Often the Class and 
KLA (or department) are 
required.

WWW1 is one of a series of computers.  

This resource prompts 
for a reason.

It also provides an 
option to book all of 
WWW Computers with 
just the one booking.
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Recurrent Bookings

Often staff want to be able to repeat a booking a number of times, usually 
based on the timetable, but occasionally on a daily basis.

A second tab displays - Recurrent Bookings

Clicking on it offers some choices...

You can repeat for the same session each timetable cycle or repeat daily

until a particular date or for a number of repeats (which includes the first 
booking).

The result of the above is shown here.

To undo the bookings, go to the original, repeat the settings, but BLANK 
the name, click Save, and they are gone...
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Linked Bookings

Linked bookings are where two resources are linked.  If you book one 
item, there is an oprion to book the other one as well.

In the example below, a library area, the Glassroom, is linked to an 
overhead projector which is separately bookable, but in another category.

First, book the Glassroom

Note the Linked Bookings 
tab

Click the linked bookings tab

Ticking the OHP, and clicking Save will 
make two bookings, one for the Glassroom 
and one for the OHP.

If there is an existing booker, you may tick 
to book it, but it won't be saved.

Locked Booking

You may occasionally see this window when you try to update a booking.

Another user of either BookIt or NetBookIt is currently updating that same 
session, so you are locked out of it.
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Deleting a booking

Clear the user name and press Save.
If the Number of Sessions to Book is more than 1, or Recurrent bookings 
are selected, or Book Entire Category, or Linked Bookings, then multiple 
bookings can be deleted in the one action, but only if they belong to that  
user.  

Log of changes to bookings

Changes to bookings are recorded in a log.  This means that if someone 
takes over another's booking, the history is recorded, and is a deterrent 
to a potential hijacker.

If a log exists for a booking, a small icon with the letter L appears next to 
the Update button.

Click on the L button to show the log (below).

Some details of the old booking are shown, along with those that 
replaced them plus when the change was made and on what computer.

If Email is configured then the user would get an email on the change of 
booking.

BookIt doesn't prevent changes, but it lets you know, and keeps the 
evidence in case the change was not approved.
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Unbookable days

You may encounter days when you can't make a booking.

For example, holidays.  
Unless an item is marked as holiday-bookable, this is what you'd see.

Some categories may limit how many days ahead you can book.

Some categories require a few days notice of bookings.

These all display as gray sessions that have no Update button.

Emails

A category may be configured to deliver emails to you when a booking is 
made or sometime prior to the occurrence of the booking.

These emails can also optionally be sent to another person, typically 
someone with responsibility for that resource such as a Science 
technician.

If you don't want to receive these emails, get the BookIt administrator to 
clear your email address from BookIt.


